Forum home Problem solving

Non blooming azalea

Can anyone tell me why my azalea hasn't bloomed?  This is it's 2nd year and I haven't pruned it at all.  It's planted near a Rhodedendron and two other azaleas which bloom without fail every year.  The site is sun during the morning and semi-shade from midday.   Thanks

Posts

  • Nanny BeachNanny Beach Posts: 5,192

    We had a white one for many years didnt flower, just about to "bin" it, took it with us when we moved, it flowered! It actually lloked dead for quite a few years, we dont prune them, try giving it a feed, give it a few mor years, you never know.  Our has tiny, not terribly outstanding flowers, but BOY what a scent!

  • raisingirlraisingirl East Devon, on the Edge of Exmoor.Posts: 4,249

    Possibly it didn't get enough water last summer/autumn. That's usually what stops them flowering. Maybe it's just that bit freer draining than the others, or there's another plant overhanging it a little that's keeping the rain off it more than its neighbours

    “It's not worth doing something unless someone, somewhere, would much rather you weren't doing it.” ― Terry Pratchett
  • JenKentJenKent Posts: 27

    Thanks.  The position where it is, WAS overshadowed by a large willow tree, but we have had it cut back considerably which lets more light and rain in.  I usually water well during dry spells.  Will give it a feed and hope the extra light will help next flowering season.  I think I got a light pink, to blend with the other two pink ones, so I'm not giving up on it!

  • Nanny BeachNanny Beach Posts: 5,192

    Yes raisingirl we have lots in pots, my hubby nags me, that it they dont get watered after flowering there wont be any the following year, they keep saying its going to rain here (near South Downs) we had a couple of spits on Friday, showing rain this afternoon and tomorrow.  All 5 water butts are empty.

Sign In or Register to comment.