Forum home Plants

Hellebores

I recently bought a couple more Hellebores plants which at the moment are in pots.

One of them has it's leaves starting to fade to a  very light green verging on becoming yellow, I guess it is lacking something but can anyone tell me what it would be. 

I have a few planted in the garden but this is the first one than I have going like this. 

«1

Posts

  • LoganLogan Posts: 2,532
    If it's old leaves they die off and grow new ones, usually you would cut them off but I don't get around to mine.It could be that their in pots have you been watering them?
  • Thanks for the reply.

    Not old leaves and they have been watered. It has been outside in the rain. 

  • LoganLogan Posts: 2,532
    Perhaps they've got waterloggedimage
  • They haven't been in pots log enough  to be pot bound and only 1 in the pot so not congested.

    I think that they need some feed but I don't know which. I have planted it in the garden now have sprinkled some Epson salt around in case it's lacking in  magnesium  and sulphur

    It could have had too much rain I guess.

     

     magnesium and sulfur,

  • Lou12Lou12 Posts: 1,149

    Hellebores do tend to have leaf problems, yellow, black etc. If I see any leaves that are going funny I just cut them off.

     

  •  I have planted them in the garden. I will wait and see now if there is any improvement. 

    Thanks for all the replies 

  • LOL.

    All of mine apart from 1 have flowered and even the poorly 1 is in flower, so I must be doing something right. They are one of my favourite flowers.

    I will dig in some chicken manure pellets around them as well later.

  • Lou12Lou12 Posts: 1,149

    Mine are still flowering their socks off as they have been for 6 months some in sun, some in shade. They've gone mad this year.

Sign In or Register to comment.