Runner beans - masses of flowers, only ONE bean.

I have 3 White Lady runner bean plants in a big pot on my patio.  It is my first attempt at growing them.  They look really healthy and have smothered the 6' wigwam with masses of leaves and flowers.  9 days ago I spotted my first miniscule bean, and felt really proud! image  But since then, absolutely nothing - just dead flowers on the ground. image  Bees don't seem to be visiting, even though I have planted some sweet peas with the runners and there are single dahlias and roses nearby.  Any suggestions?

Posts

  • LynLyn Posts: 8,374

    They need gallons of water in this drought, thats probably the problem. I think most people are in the same boat at the moment. You could spray them.

    Gardening on the wild, windy west side of Dartmoor. 
  • ItalophileItalophile Posts: 1,647

    Yup. Don't let them dry out when flowering.

  • I've started giving them a good soak twice instead of once a day, and have also misted the flowers, so we'll see what happens!  I'll let you know .....

  • Am pleased to report that eventually I had a bumper crop of runner beans and twining stems reaching up to the half landing window! (see photo).  I've left a few to mature on the plant for beans to plant next year.  Do you have to wait till the pods turn brown before picking, and how long does that take?  Most of the leaves have now dried/dropped off.  Should I continue watering until the pods are ready to harvest?

    image

     

     

Sign In or Register to comment.