Fuschia problem

Any ideas what can be wrong with my Fuschia Gennii. It has been perfectly happy all "summer"... lots of leaves and flowers....really beautiful.

Now it is shedding its leaves and flowers on one side only.

It is planted in a border facing S & E, doesn't get heat from sun after 2pm, is well watered and fed with Miracle grow twice since May. There is no sign of Vine weevil and all other plants in the border look OK.

The plant is in its second year

Any ideas??

Posts

  • figratfigrat Posts: 1,619
    When you say there are no signs of vine weevil are you looking for tha adults or the grubs?
  • kate1123kate1123 Posts: 2,815

    The tough answer is to dig it up and inspect the roots.

  • my fuschia's (two) in pots are beautiful plants,green, healthy and strong , but hardley and flowers on them this year.?? any clues as why.??.

  • LeggiLeggi Posts: 489
    flower 7 wrote (see)

    my fuschia's (two) in pots are beautiful plants,green, healthy and strong , but hardley and flowers on them this year.?? any clues as why.??.

    Like a lot of things this year, the weather. It's just not been that warm or sunny for long enough spells.

  • sotongeoffsotongeoff Posts: 9,806
    flower 7 wrote (see)

    my fuschia's (two) in pots are beautiful plants,green, healthy and strong , but hardley and flowers on them this year.?? any clues as why.??.

    Have you fed them and if so with what?

  • figratfigrat Posts: 1,619
    My hardy fuchsias are only just coming into flower - lots of healthy growth otherwise. I think it's generally been a naff gardening year.
  • If they are potted and you 've potted them on to a bigger pot, the pot must only be the next size up. Putting them straight into a large pot will result in luxuriant green foliage and no or few .flowers

  • My fusia's in post as normal are starting to get yellow leaves. I've fed they miricle grow as normal so ,don't know what the problem is.

Sign In or Register to comment.