Aubergine woes

I grew some standard aubergines from seeds, some in a raised bed (partly shady) and some in pots (full sun)

Both lots produced nice big healthy plants, but took ages to flower and then fruit never appeared. From a total of about 10 plants 1 grew 1 aubergine image

I fed them as soon as the flowers came out and continued to do so.

Anyone have any tips or ideas of what i did wrong?

Thanks image

Posts

  • KEFKEF Posts: 8,915

    Steve, I understand that Aubergines need a long, warm Summer and plenty of sunshine, not shade. I've only grown them twice and had them in the GH until mid summer and then outside. I got some fruit but nothing of any decent size. Flowers were lovely. You don't feed them until you have fruits on the plant.

  • DovefromaboveDovefromabove Central Norfolk UKPosts: 43,612

    I've not grown them myself but I  understand they really do require a long hot summer - longer and hotter even that the one we've just had.  However there are now some varieties recommended for cooler climates like ours, rather than their native Asia.  Some info here http://www.rhs.org.uk/Gardening/Grow-Your-Own/Veg-A-to-Z/Aubergine image

    No-one knows if you've done your housework, but everyone knows if you've done your gardening !
  • Thanks Kef,

    Ah i fed them to soon (thus the lovely plants image )

    I will keep them inside for a bit longer next time, i have a south facing patio which hopefully should be warm enough for them. The strange thing is the 1 fruit i did get was from a plant in the shade??

Sign In or Register to comment.