Forum home Plants

Delphinium buds not forming properly?

CraighBCraighB Posts: 758
Hi guys,

I have a couple of delphiniums and strangely the buds on one plant have not grown all the way up the stem. You can see where buds are supposed to be but there is nothing there and it doesn't look like they have been nibbled off either because it's the same lower ones on every stem. It's like there are only buds towards the tip of each stem.

However the other delphinium I have which is the same variety and only 1 meter away has produced completely normal looking buds.

Has anyone seen this before? The last photo is the plant which looks normal.

Posts

  • JacquimcmahonJacquimcmahon Posts: 1,023
    I had a couple do this last year. Just put it down to variation as everything was fine otherwise and they were still pretty when they opened.
    Marne la vallée, basically just outside Paris 🇫🇷, but definitely Scottish at heart.
  • Bright starBright star Posts: 1,153
    I have a delphinium that also has normal looking flower heads and a misshaped one, i had the same last year too but on different delphiniums plants, they are normal this this year. I believe it’s called fasciation. Last year it looked as though someone had flattened the flower spike. There was an interesting thread about fasciation on the forum last year.
     Mine looked like this last year.



    Life's tragedy is that we get old too soon and wise too late.

  • CraighBCraighB Posts: 758
    Ah yes yours do look similar to mine.

    Hopefully next year they will be fully formed! I've been trying to grow delphiniums now for years and never got them to produce huge flower spikes and I thought this year would be the one because the stems were very very thick! But never mind there is always next time :)
Sign In or Register to comment.