Forum home Tools and techniques

Hyundai Rotovator

Bought a Hyundai HYT140 rotovator last April, used it a few times but last time out the engine starts OK but it won't drive.  It's under guarantee but too expensive to return so I thought I'd have a go myself.  Doesn't look like the clutch as it's going all the way back so maybe the belt.  Anyone any experience of Hyundai, is this something I could tackle?

Posts

  • BobTheGardenerBobTheGardener Leicestershire, UKPosts: 11,066
    Don't know that one but worth double-checking the clutch adjustment - see section 2.4.4 in the manual:

    A trowel in the hand is worth a thousand lost under a bush.
  • Allotment BoyAllotment Boy North London Posts: 4,082
    I don't know that particular machine, but if it's belt drive that is a likely suspect and usually fairly easy to adjust. Check also that there is nothing wrapped round the tines or drive shafts (nylon string, bindweed etc).
    AB Still learning

  • Thanks for the replies.  Turns out the belt was off.  Removed 6 bolts and re-seated it and going well now.  Belt looked worn which is surprising as I've used it so little.
  • RoyHRoyH S. YorkshirePosts: 6
    thomasj said:
    Thanks for the replies.  Turns out the belt was off.  Removed 6 bolts and re-seated it and going well now.  Belt looked worn which is surprising as I've used it so little.
    Probably it was running a bit slack and slipping a bit before it came off hence the premature wear
Sign In or Register to comment.