Forum home Plants

Hibiscus won’t bloom

BigDog AlBigDog Al Posts: 9
hi I’ve had 5 hibiscus plants in different parts of the garden for 3 years, the problem is they have never bloomed, they’re getting sunlight and after reading that they need fed to be happy I’ve made a point of giving them a little bit extra to my other flowering shrubs, I’ve used miracle gro and Tom feed alternatively, any advice??

Posts

  • I’ll be interested to hear any comments too. I have had one for 4 years and not had one flower. Foliage is very healthy. My sister who lives across the road from me has had hers for about 5 years and it blooms profusely every year - she has never fed it 🤷🏻‍♀️

  • ERICS MUMERICS MUM Posts: 527
    Mine opened the first of its many buds today (far more buds than I’ve ever seen in previous years), earlier than usual which I suppose is due to the weather.  It stands against the house wall in a south facing garden in East Anglia so it’s been well and truly baked for a good couple of months.  I give it the odd splash of tomato food once a month.
  • BigDog AlBigDog Al Posts: 9
    The foliage on them all is very healthy but there is no sign of budding as yet, on the warm days they’re getting 5 hours of solid sun, very frustrating 
  • ERICS MUMERICS MUM Posts: 527
    BigDog Al said:
    The foliage on them all is very healthy but there is no sign of budding as yet, on the warm days they’re getting 5 hours of solid sun, very frustrating 
    Have you fed them ?  Try some tomato food.
  • karen paulkaren paul Posts: 230
    Me too! I've had one for at least 5 years and not one single flower! Its been in 2 different places in the garden, the 2nd place more sunny to no avail. My sister who lives around the corner not only has one that flowers profusely but has 2 different colour blooms on one plant. Mine has been fed with my own homemade plant feed every now and again plus bone meal. 
Sign In or Register to comment.