More hozelock woe

Hi

My oldish hose on a reel was working fine, but now this happens... 

https://goo.gl/photos/FEUUk1pN97dGcbSp9

The male part did unscrew the other week, popped it back on, but now you can't move the wheel without the hose blowing off. The pressure is high but it was working fine until recently. Worth replacing any bits? 

John

Posts

  • ObelixxObelixx Vendée, Western FrancePosts: 16,246

    The bits are easy enough to find and not that expensive so yes, replace the male part as well as the female on the end of your feed hose and see if that helps.

    If that doesn't work, contact Hozelock directly for advice.

    Last edited: 20 June 2017 20:22:29

    "We don't stop playing because we grow old; we grow old because we stop playing." - George Bernard Shaw
  • KT53KT53 Posts: 3,278

    Oddly enough I had the same problem with a Hozelock connector to a Hozelock reel.  Replaced the connector and I've had no further problem.  I suspect it's just a case that the retaining clip on the connector weakens over time, and the higher the pressure the greater the likelihood of failure.

  • JOHN504JOHN504 Posts: 10

    I replaced the female connector and it seems fine, but I can't work out what size the male connector is... 

    https://goo.gl/photos/b4s3vAVde87ohsUu8

    Frustrating! 

  • ObelixxObelixx Vendée, Western FrancePosts: 16,246

    Remove it and take it with you when you go to buy a replacement.

    "We don't stop playing because we grow old; we grow old because we stop playing." - George Bernard Shaw
Sign In or Register to comment.